№ 7696 (Уровень: Сложный)
(Грачев Н.) Марсианин Саша составляет странные 18буквенные слова из букв 
Е,В,Л,А,М,П,И,Й. Сколько существует различных странных слов, в которых в начале
 слова находится сочетание букв ПИЛАЕВЛА? Слово считается странным, если кол-во
 гласных и согласных букв в слове одинаково.

191362500


import itertools as I
import itertools
def f(code,cg,cs):
    d = []

    if code==10:
        return cg==cs
    else:
        d.append(f(code+1,cg+1,cs)*3)
        d.append(f(code+1,cg,cs+1)*5)
    return sum(d)
count=0
print(f(0,0,0))